Guide activation - multiple elements

August 14, 2023 Update: This appears to be working correctly now. If it is not working correctly for you, please submit a Support ticket and they can work with you on additional troubleshooting: https://support.pendo.io/hc/en-us/articles/360034163971-Get-help-with-Pendo-from-technical-support

--------------------------

When using target element activation, you can set up a guide to activate for either of these scenarios:

  • A: The specific element (ie. a star icon) appears on the page more than once . A click on any of those elements (star icons) will activate the guide

    OR

  • B: You have multiple elements (ie. a star icon, a question mark icon, etc.). A click on either of those elements (star icon or question mark icon) will activate the guide. 


When setting this up in the Pendo Designer, you will get a warning that says "more than 1 element found". That’s okay, and you can ignore that warning.

  • For situation A (multiple instances of the same element), you would just need the one CSS selector.
  • For situation B (several different elements), you would need a CSS selectors for each element and separate them with a comma in the Custom CSS field. 

 

There are a few things to keep in mind:

  • Pendo caps activation elements at 50. Most clients don't ever get close to this limit.

  • We recommend using a lightbox as the layout for the guide step instead of a tooltip.

  • If you use a tooltip, it will only point at the first matched target element. This can be confusing to the user.  If they clicked on the 3rd instance of the element, the guide activates, and points at the first instance of the element instead.

2

Comments

11 comments
  • Official comment

    Johan Hedlund, Michael Stanek Michael Garrity Rachana Kumari, if you are still having trouble with guide activation for multiple elements, please reach out to our Support team and they can help troubleshoot. Please grant access to your subscription and create a ticket using the instructions in this article: 

    https://support.pendo.io/hc/en-us/articles/360034163971-Get-help-with-Pendo-from-technical-support 

    I got confirmation from Engineering that we should be able to activate a guide using a CSS selector (or comma separated list of CSS selectors) that match multiple elements. I also ran several tests myself using the most recent Pendo agent versions  2.197.0_prod and 2.198.0_prod, and each time it worked correctly. 

    If you're having trouble with the guide activation, Support can take a closer look at your exact setup and help diagnose the issue. 

     

  • Kevin Gosman, these instructions do not work for badge activation. They only work for target element activation. What you are seeing with the badge activation is expected behavior. If you'd like to se something different, please submit a feature request to our Product Team (while in Pendo, click on the Pendo Resource Center icon in the lower left hand corner, and select 'Share Your Feedback')

    1
  • Angela-Holly -- I saw your comment that this no longer works.  Is this currently a bug that will be addressed at some point? Or is it that this method is no longer supported by Pendo moving forward?

    1
  • Angela-Holly - question on this: I'm setting up a guide to be activated via badge click, where the target element can appear on the page multiple times.

    When setting the location for step 1 of the guide (which sets the badge location), I enter the CSS selector and am (correctly) getting the "more than 1 element found" message. Within the pendo designer on my application, I'm seeing all instances of the element correctly highlighted.

    Once I stage the guide, only the first element on the page is showing the badge, and the subsequent elements don't have a badge. Anything I'm doing wrong here?

    0
  • Ah got it - thanks Angela-Holly. For target element, it looks like we're running into the same issue, where even though the elements are correctly highlighted in the designer, only the first element on the page is activating the guide once staged. Any troubleshooting steps?

     

    0
  • Kevin Gosman that's unexpected and I'd recommend contacting our Support team for further troubleshooting. 

    https://support.pendo.io/hc/en-us/articles/360034163971-Creating-Reviewing-Your-Support-Cases-from-Resource-Center

    0
  • Hi, I'd like to resurrect this discussion. Did you find a solution to the issue? I'm having the same problem, and although the designer highlights both the target elements I want to use, only one of them shows on top of the backdrop. If I remove the backdrop, it's still only one element that is recognized by the guide when I click on it.

    0
  • Has this been fixed? It would be really helpful. 

    0
  • Can someone please help in here? for tagging the same guide for multiple elements.

    0
  • Rachana Kumari can you please elaborate.

    You can connect with me on LinkedIn.

    0
  • Can someone help with this error.

    (index):1957  crbug/1173575, non-JS module files deprecated.
    (anonymous) @ (index):1957

    0

Please sign in to leave a comment.

Didn't find what you were looking for?

New post