[rn-pendo-sdk] ReactNativePendo is not available. Ignoring call.

I am working on integrate pendo to our Expo managed flow project according to this doc https://support.pendo.io/hc/en-us/articles/10359221496475-Expo-with-React-Navigation#step-2-pendo-sdk-integration-0-1


but it keep says '[rn-pendo-sdk]  ReactNativePendo is not available. Ignoring call.'

But It works when running a build apk.

I want to know if pendo works on simulator(expo go)?


What's wrong with it?



  • What's going on with pendo, weeks go, no one reply, I even can not find a live support!

  • Having the same issue with our implementation, and am having such a bad experience with Pendo this morning. Tried to investigate on the rn-pendo-sdk / react-native-pendo-sdk github repo (linked to from NPM) but it doesn't exist for some reason. Then tried to comment on this thread, but I had to have an account, which just spun and spun when I tried to create one (also who requires a 12 character PW???). Turns out it didn't like that I had an ad blocker on but it wasn't self-aware enough to give me an error or a warning. After figuring that out, logged in and was presented with 3 or 4 survey prompts. Just a nightmare of a UI. Long story short, we get this `console.info` with every single one of our unit tests...