This article provides guidance for when you're creating a visitor segment using the metadata fields "Account ID" or "Account IDs" and need clarification on the difference.
Note: While viewing eligible visitors for a segment created with the Account ID rule shows all visitors who were ever associated with the Account ID, applying this segment to a report or guide only targets visitors who have had their last activity as the Account ID specified in the rule.
Product area: People > Segments (web, mobile)
Issue
If you create a segment to review analytics for a specific account, it's possible for visitors that are associated with other accounts to display in the metrics.
For example, if you apply a segment with the rule Account IDs contains Test Account 4 to a visitor report, you might see results with Account IDs that differ from the Account ID you specified in the segment: Creed.Bratton as the Visitor ID in Test Account 1 and Test Account 2.
Diagnosis
Pendo has two different, yet very similarly named, metadata fields: Account IDs at the visitor level and Account ID at the account level. If you see results from multiple accounts but only want to see results from one account, you might need to use Account ID in your segment instead of Account IDs.
Despite having similar names, each field yields different results. It's important to understand when to use each field in a segment and what to expect from the results.
Metadata field | Definition |
Account ID |
The Account ID value that a visitor was assigned at the time an event occurred. This is always a single value. When selecting this field in the segment builder, it's always in the Account Data section and has a double-headed icon. |
Account IDs |
A list of all Account ID values a visitor has ever been associated with. This could be a single value or a list of values. When selecting this field, it's always in the Visitor Data section and has a single head icon. |
Solution
To ensure you're seeing the expected results, make sure you're using the appropriate metadata field.
- If you use a segment with Account ID for a report, Pendo only displays the events for the visitor that were associated with that specific Account ID at the time they generated that event.
- If you use a segment with Account IDs for a report, Pendo displays the events for the visitor for every account they have ever been associated with, as long as they were associated with the Account ID in your segment at some point in time.
In the scenario mentioned in the Issue section earlier, Account IDs was used for the segment rule. The visitor, Creed.Bratton, generated events while associated with Test Account 4 at one point in time.
You can confirm this by verifying the account is listed on their visitor details page by navigating to People > Visitors and selecting their Visitor ID from the list of visitors:
This means that this visitor is a match for the segment and Pendo returns all events that Creed.Bratton has generated across any account, even if it’s not from Test Account 4.
If you only wanted to see the events Creed.Bratton generated while associated with Test Account 4, you'd need to switch the segment rule to Account ID is equal to Test Account 4.
For more information about metadata and segments, see our articles on Configure visitor and account metadata and Segments.