Error: No Matching API Key

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This article provides guidance for when you see a "No Matching API Key" error when trying to launch the designer (Visual Design Studio) over your application.

VDS_NoMatchingAPIKey.png

Product area: Guides > Designer (web)

Issue

Typically, the error "No Matching API Key" is displayed when Pendo isn't being initialized properly on your application. It indicates that the initialize function isn't being called, or that a field within the function isn't being populated correctly. For a reference of initialization functions, see the developer documentation.

Diagnosis

Confirm that Pendo isn't initializing on your page.

After clearing your cache and re-launching the designer, you need to validate your Pendo install. 

  1. Right-click on your website, then select Inspect from the dropdown menu.
  2. Paste pendo.validateInstall() into the browser developer console.
  3. Select Enter to return metadata.

If you receive an error message that your Pendo API key isn't configured, that means Pendo isn't initialized on your page. 

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If Pendo is initialized successfully but you still see the No Matching API Key error when launching the designer, confirm that the API key in your install script is associated with the correct Pendo subscription and application. In particular, check that the value of pendo.publicAppId in your install script matches the Public App ID shown in your application’s settings in Pendo.

Solution

Update your Pendo install script to include error handling using the initialize() function in your code, which allows Pendo to initialize completely.  

For more information about updating your install script, see our Developer's guide to implementing Pendo using the install script.

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