"Company Owner" is coming through as an ID in my account

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This article provides guidance for when your HubSpot integration returns Company Owner in your metadata instead of a named string value.

Product area: Integrations > HubSpot integration (web)

Issue

Typically, Company Owner is returned as a value in your metadata when HubSpot has defined that field as an innumerable and the expectation of a string is inaccurate. When we query for the value of this field, HubSpot passes the ID rather than the name associated with it. 

Diagnosis

Before adjusting your metadata fields, check your integration setup. Check that the integration is authenticated with the correct account in HubSpot. If you have multiple HubSpot accounts, select the account you want to sync with Pendo from the list of accounts. If the wrong account was authenticated, re-authenticate with the correct account. 

After checking your account setup, ensure the Company Owner field passes the correct ID in your HubSpot settings. 

Solution

Set up your metadata for both visitors and accounts. The values for the Pendo IDs must exactly match the values in HubSpot. Verify that the fields you've selected in your metadata sync with the fields that you want to pull from HubSpot. 

For more information about the HubSpot integration, see Two-way HubSpot integration with Pendo.

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