サポートされているモバイルフレームワークとオペレーティングシステムのバージョン

最終更新日:

この記事は開発者向けです。Pendo SDK(ソフトウェア開発キット)がサポートするモバイルフレームワークとオペレーティングシステム(OS)に関する技術的な詳細と、各フレームワークがノーコードトラッキングまたはトラックイベントのみをサポートしているかどうかを説明しています。

supported frameworks.png

また、Pendo SDKがテストされる環境に関する情報も提供します。Pendo SDKの技術情報については、PendoモバイルSDKを参照してください。

サポートされているフレームワークの要件

フレームワーク バージョン 開発システム ノーコードまたはトラックイベントのみ
Android

SDK 3.x:
API 21 - API 34
Kotlin 1.9.0
JAVA 11以降

SDK 2.x:
API 21 - API 34
Kotlin 1.7.20
JAVA 8以降

SDK 2.19.1以降
Android Gradleプラグイン7.2~8.2(8.2を含む)

SDK 2.19.1以前:
7.2までのAndroid Gradleプラグイン(7.2は含まない)

Jetpack Compose UI - トラックイベントのみ


閲覧ベースのUI - ノーコード

 

 

iOS

SDK 3.x:
iOS11 - iOS17

SDK 2.x:
iOS9 - iOS17

SDK 3.x:
xCode 14以降
Swift互換性5.7以降

SDK 2.x:
xCode 13以降
Swift互換性5.6以降


SwiftUIとUiKit - ノーコード

 

 

Xamarin

SDK 2.x - .NET 4
SDK 3.x - サポート対象外。

Xamarin.FormsまたはMauiプラグインをご利用ください。

  ノーコード
Xamarin Forms

SDK 3.x:
Forms 5.0.0.2612
.NET 4
Android 13以降

SDK 2.x:
Forms 5.0.0.0
.NET 4
Android 12以降

  ノーコード
Maui

SDK 3.x:
.NET 7/8
Android 13

SDK 2.x:
.NET 6/7
Android 13

IDE - Visual Studio 17.4

SDK 3.1以降
.net7、.net8に対応

SDK 3.0以降
.net7に対応

SDK 2.x:

.net6、.net7に対応

ノーコード

React Native 0.60~0.72
0.60~0.68のテストは終了
 

カスタムナビゲーション - トラックイベントのみ

  • React Navigation

5.x、6.x

  ノーコード
  • React Native Navigation

6.x、7.x

  ノーコード
Expo SDK 41 - 50  

Expoルーターとその他のナビゲーションライブラリ - トラックイベント

 

Expo Go - サポートされていません

  • React Navigation

5.x、6.x

  ノーコード
  • React Native Navigation

6.x、7.x

  ノーコード
Flutter

SDK 3.x:
3.3.0以降
Dart 2.18以降

SDK 2.x:
2.0.0 - 2.10.5
Dart 2.12.0-2.16.2

  トラックイベントのみ

 

注:ハイブリッドアプリを使用している場合は、 ハイブリッドアプリでPendoを使用するを参照するか、Pendoサポートにお問い合わせください。

テスト環境

以下は、Pendoが各リリースの前にSDKをテストする環境のリストです

フレームワーク テスト時のOSバージョン
Android
  • API 29、31、34
iOS
  • iOS 16.2、16.4、17.0
Xamarin Forms Shell
  • iOS 16.2、16.4、17.0
  • Android API 29、31、34
Maui
  • iOS 16.4、17.0
  • Android API 31、34
React Native Navigation
  • iOS 16.2、16.4、17.0
  • Android API 29、31、34
React Navigation
  • iOS 16.2、16.4、17.0
  • Android API 29、31、34
Expo
  • iOS 16.2、16.4、17.0
  • Android API 29、31、34
Flutter
  • iOS 16.4、17.0
  • Android API 31、34

 

この記事は役に立ちましたか?
3人中2人がこの記事が役に立ったと言っています